[KPhotoAlbum] Command line filtering

Robert Krawitz rlk at alum.mit.edu
Mon Feb 25 00:20:35 CET 2019


On Sun, 24 Feb 2019 22:23:24 +0100, Johannes Zarl-Zierl wrote:
> Am Sonntag, 24. Februar 2019, 22:07:03 CET schrieb Robert Krawitz:
>> > 1. Calling kpa-filter without arguments loops indefinitely
>> > At least, it seems like this - I used Ctrl-C after a few minutes. I'm not
>> > sure what the intended outcome would be. I had expected either a listing
>> > of all files in the index.xml or just the help message.
>> On my system, it does list every file (that's what it's supposed to do).
>
> Maybe my version of perl is too old or something? I'm using perl 5.28.1
>
>> > 2. How do I use the "--db" option?
>> > I tried the following command in the kphotoalbum source directory:
>> > $ kpa-filter --db "$PWD/demo/index.xml"
>> > Could not create file parser context for file "1": No such file or
>> > directory at contrib/kpa-filter line 494.
>> Bug, fixed in the latest.
>> 
>> > 3. The "--count" option does seem to do nothing in the following call:
>> > $ kpa-filter -c -l cat:Keywords
>> 
>> Another bug fixed in the latest (ef1864e897fe65d27efb8e34f13bd1252e62cbdb).
>
> Strange - I did all my tests using ef1864e897fe65d27efb8e34f13bd1252e62cbdb

OK, my bad at lesat with #2 and #3.  I had fixed two other bugs that
looked similar (one of which was and one wasn't).

I cannot reproduce #1 (at least with my index.xml file).
-- 
Robert Krawitz                                     <rlk at alum.mit.edu>

***  MIT Engineers   A Proud Tradition   http://mitathletics.com  ***
Member of the League for Programming Freedom  --  http://ProgFree.org
Project lead for Gutenprint   --    http://gimp-print.sourceforge.net

"Linux doesn't dictate how I work, I dictate how Linux works."
--Eric Crampton


More information about the KPhotoAlbum mailing list