[KPhotoAlbum] Problem running in Fedora 28

Johannes Zarl-Zierl johannes at zarl-zierl.at
Wed May 23 00:47:39 CEST 2018


Hi,

Am Dienstag, 22. Mai 2018, 19:18:28 CEST schrieb Constantin Orăsan:
> Below you can find two traces. In the first case I have a number of images
> in the directory.

The crash is happening in libexiv2, apparently.

> In the second case, I have only one video, but I did not
> install the support to generate thumbnails from videos.

The second crash has triggered an assertion. Is there any output on the console?


> I see that the
> traces are different. This is done using the latest version from github. I
> hope it helps.

I find github to be a little confusing as to which repository is the right one. Just to be sure, 
you mean this one?
-> https://github.com/KDE/kphotoalbum
This one is the github mirror of the official repository.
The official repository itself can be found at https://phabricator.kde.org/source/
kphotoalbum/ or https://cgit.kde.org/kphotoalbum.git/.

> Thread 1 "kphotoalbum" received signal SIGABRT, Aborted.
> #3  0x00007ffff7760dab in std::vector<std::pair<unsigned int, unsigned
> int>, std::allocator<std::pair<unsigned int, unsigned int> >
> >::operator[](unsigned long) const (__n=<optimized out>, this=<optimized
> out>)
>     at ../include/exiv2/value.hpp:1719
> #4  0x00007ffff7760dab in Exiv2::ValueType<std::pair<unsigned int, unsigned
> int> >::toRational(long) const (this=<optimized out>, n=<optimized out>) at
> ../include/exiv2/value.hpp:1719
> #5  0x00000000005ecceb in
> Exif::RationalExifElement::valueFromExif(Exiv2::ExifData&) const
> (this=0x1e9b510, data=...) at
> /home/dinel/kphotoalbum/Exif/DatabaseElement.cpp:143



> #5  0x00000000005666d4 in ImageManager::ThumbnailBuilder::instance() () at
> /home/dinel/kphotoalbum/ImageManager/ThumbnailBuilder.cpp:71
> #6  0x0000000000580e94 in DB::NewImageFinder::findImages()
> (this=0x7fffffffbfa0) at /home/dinel/kphotoalbum/DB/NewImageFinder.cpp:76

This basically means that the ThumbnailBuilder was called before it was initialized.

Maybe it's worthwhile for you to check out Roberts branch "Load-performance". He did find 
(and fix) some threading issues in the thumbnail builder.

Cheers,
  Johannes

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kdab.com/pipermail/kphotoalbum/attachments/20180523/816ffdcc/attachment-0001.html>


More information about the KPhotoAlbum mailing list