[KPhotoAlbum] *startup-performance* branch

Robert Krawitz rlk at alum.mit.edu
Mon Aug 20 02:21:26 CEST 2018

On Sat, 18 Aug 2018 21:19:15 +0200, Johannes Zarl-Zierl wrote:
> This week I had a first look at it. I'm not on my PC right now and
> therefore can't look at the patches for writing this response, but
> my initial thoughts were:
> I'd like a better name for the doDirty() method (but I couldn't come
> up with one right away).

How about markDirty()?

> The trick of shortcutting the MemberMap.contains() lookup seems OK,
> but I wanted to do a second reading to make sure I understood it
> correctly.

This is only done when loading; otherwise, the logic is the same as it
was before.

> On that note: since the lookup is only updated during m_loading
> time: can it get incorrect results e.g. by removing (sub)categories
> and then re-adding some of them?

I've fixed the remove code to always rebuild the flat list to avoid
issues in that regard.

I am assuming that nothing ever gets deleted while loading; perhaps I
should add an assertion to that effect?
Robert Krawitz                                     <rlk at alum.mit.edu>

***  MIT Engineers   A Proud Tradition   http://mitathletics.com  ***
Member of the League for Programming Freedom  --  http://ProgFree.org
Project lead for Gutenprint   --    http://gimp-print.sourceforge.net

"Linux doesn't dictate how I work, I dictate how Linux works."
--Eric Crampton

More information about the KPhotoAlbum mailing list