[KPhotoAlbum] error compiling in Ubuntu 16.04 and Mint 18.3

Andreas Schleth schleth_es at web.de
Mon Dec 18 22:03:44 CET 2017


Hi Johannes,

here are the revisions:

opensuse 42.2: KDE 5.26 / QT 5.6.1 - compiles and looks good
Ubuntu 16.04 / Linux Mint 18.3: KDE 5.18.1 / QT 5.5.1 (Mint ships with 
KPA 4.7) - compilation of git master fails (last working rev. was 5.1 - 
did not show icons)
Ubuntu 17.10 / Kubuntu 17.10: KDE 5.38.0 / QT 5.9.1 (17.10 ships with 
KPA 5.2) - icons don't show up in Gnome/Unitiy-Ubuntu but are OK in Kubuntu

As Mint is quite popular and will always be based on a LTS-revision of 
Ubuntu, I strongly suggest to have at least the releases compatible with 
the latest LTS-Version, even if the libs are a bit outdated. I guess, 
Ubuntu LTS + Mint combined will have a relative majority among all Linux 
desktops, esp. among more casual users.

KPA has a really good "WAF-Factor" (at least here it makes the top five: 
Browser, Mail, Office, PDF-Reader, KPA). So I expect the "casual user" 
could be KPAs prime target.

Regards, Andreas



Am 17.12.2017 um 23:06 schrieb Johannes Zarl-Zierl:
> [sending again, this time to the list address]
>
> Hi Robert,
>
> On Sonntag, 17. Dezember 2017 16:56:41 CET you wrote:
>>> The relevant difference is the version of Qt: OpenSUSE leap 42.1 still has
>>> Qt 5.5 (leap 42.2 and Mint 18.3 probably as well).
>> 42.1 is outside of its support window, IIRC.
>>
>> 42.2 uses Qt 5.6.
> I seem to have misread the original mail. Thanks for pointing this out.
>
> I've now read up on Linux Mint: 18.3 is the latest version - how can this
> still use Qt 5.5? Am I missing something there?
>
> Cheers,
>    Johannes
>
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at mail.kdab.com
> https://mail.kdab.com/mailman/listinfo/kphotoalbum
>



More information about the KPhotoAlbum mailing list