[KPhotoAlbum] KPA 5.1 issue list

Johannes Zarl-Zierl johannes at zarl-zierl.at
Fri Dec 30 23:29:42 CET 2016


On Mittwoch, 28. Dezember 2016 19:15:50 CET Tobias Leupold wrote:
> > 4. At least in one install, parts of the menu entries had been missing,
> > due to missing permissions on
> > /usr/local/share/kphotoalbum
> > /usr/local/etc/xdg/kphotoalbumrc
> > (and sub dirs in the path)
> > Note that I build as a normal user, but install as 'root'.
> > At the same time my root account has a limited umask (077) set.
> > I guess the install process should give explicit permissions, instead of
> > relying on umask or the one already present on installed files.
> 
> Probably also a porting issue. Interestingly, no bug concerning this was
> filed yet – I don't think anything about the install process was changed.
> But it's Johannes who's the cmake expert.

There's not much that we can do w.r.t. permissions. CMake docs state:
"Files [...] are by default given permissions OWNER_WRITE, OWNER_READ, 
GROUP_READ, and WORLD_READ if no PERMISSIONS argument is given."

[source:
https://cmake.org/cmake/help/v3.7/command/install.html#installing-files]

That means that even if we set this explicitly, your umask will probably 
interfere in the same way. Do you have the same problem with other cmake-based 
installers?


> > 5. Starting on the command line gives a hint/warning
> > gollum:> kphotoalbum
> > KXMLGUI file found at deprecated location
> > ("/usr/local/share/kphotoalbum/kphotoalbumui.rc") -- please use
> > ${KXMLGUI_INSTALL_DIR} to install this file instead.

Should be fixed in git master (518f0503). Can you please verify this?

Cheers,
  Johannes



More information about the KPhotoAlbum mailing list