[KPhotoAlbum] KPA 5.1 issue list

Martin Jost lists at majo.name
Wed Dec 28 18:59:55 CET 2016


Hello,

[haven't seen this mail on the list; second try with fixed
'from'-address; hopefully you now don#t get it twice...]

here are the open points, I see in KPA 5.1.
Let me know, in case I should open bug tickets for these for better
tracking.

This is on openSuse 42.2, patched up to date. KPA 5.1 is compiled from
source tar-ball. There had been previous versions installed before, last
had been 5.0.1. (And as a try a state from GIT)

1. KPA 5.1 might crash after reading new images, if "ffmpeg" isn't
installed.
I just re-checked and had to add this "might".
KPA crashed reproducibly when it had to read a bigger bunch of photos
from my DSLR (24 MPixel). It had no problems, if "ffmpeg" was present.
Now I deinstalled ffmpeg and added another single 8 MPixel photo from my
mobile. But this time it didn't crash and read the new photo.
So there seem to be more aspects involved.
I'll do a cross-check on "my other" computers, as soon as I get in their
reach again.
Note that mplayer had been present all the time, but mplayer2 hasn't (No
longer available)

2. "Maintenance/Build thumbnails" doesn't seem to work
If I start this, the progress bar stays at 0 %, even if I leave it ~ 1
h. It also seems to me, that only the thumbnails are created, where I
scroll the view to.

3. Annotation dialog too high
The annotation dialog started out (much) too high.
Probably because of this new 'map' in it.
The buttons were pushed down below the visible space on the screen.
That happened on the laptop as well as on the much bigger PC displays.
This can be solved by editing sizes and contents and then save this.
But I guess for newbies, this is much too well hidden.

4. At least in one install, parts of the menu entries had been missing,
due to missing permissions on
/usr/local/share/kphotoalbum
/usr/local/etc/xdg/kphotoalbumrc
(and sub dirs in the path)
Note that I build as a normal user, but install as 'root'.
At the same time my root account has a limited umask (077) set.
I guess the install process should give explicit permissions, instead of
relying on umask or the one already present on installed files.

5. Starting on the command line gives a hint/warning
gollum:> kphotoalbum
KXMLGUI file found at deprecated location
("/usr/local/share/kphotoalbum/kphotoalbumui.rc") -- please use
${KXMLGUI_INSTALL_DIR} to install this file instead.

6. "Settings birthdays" duplicates the year in the GUI
If I select in "Settings birthdays" a date e.g. 28. Dec. 2016, I get as
result in the left pane "28. Dec. 20162016".
The same happens, if I enter a date by hand.
This seems to be a presentation problem. If I look at index.xml I find e.g.:
             <value value="Copyright" id="42" birthDate="2000-01-06"/>

7. Too many double clicks
In my system settings, I have configured KDE to use double clicks to
"open files and folders " (as the explanation says)
Now I have to also use double clicks e.g. to "enter" the different top
level items on the main screen. ("People", "Places", ...)
Even if I want to select an entry in "Settings/Birthdays" I need a
double click.
These turn to single clicks, if I change this KDE setting.
But because I want this "single click to just select", this is no good
option.
The behaviour had been single clicks, irrespective of the settings in
previous versions. (I assume this is an effect of KDE4 <=> 5 and not a
conscious change in KPA itself)
Is there a way to change this ?

Regards

Martin

P.S.:
Now I need my usual "disclaimer":
This is no ranting on KPA - I like the program very much.
Thanks for all the effort spend on it !

And: I'll be out of reach of a usable internet until the second week in
Jan. So please give me time to answer on requests concerning this.


More information about the KPhotoAlbum mailing list