[KPhotoAlbum] Build instructions have been updated

Harald Barth haba+kphotoalbum at kth.se
Sun Dec 11 15:35:09 CET 2016


> The new instructions should work for KDE Frameworks (kphotoalbum 5.x). If you 
> notice any problems, please respond here...

Well, I still can't build because somehow cmake requires ECM (not
mentioed on web page) and my current install (Mint 17.1 Rebecca) does
not provide ECM and I have not found an instruction how to build ECM.
This is typical yak-shaving.

Harald.

Error message:

habook:build$ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
CMake Error at CMakeLists.txt:13 (find_package):
  Could not find a package configuration file provided by "ECM" with any of
  the following names:

    ECMConfig.cmake
    ecm-config.cmake

  Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
  to a directory containing one of the above files.  If "ECM" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/src/kphotoalbum-git/kphotoalbum/build/CMakeFiles/CMakeOutput.log".



More information about the KPhotoAlbum mailing list