[KPhotoAlbum] regression: problem with extracting video length

Reimar Imhof Reimar.Imhof at netcologne.de
Sun Dec 4 22:10:56 CET 2016


Hi Johannes,

just an other idea:
What about videos that do just have a video track.
Perhaps the test could just ensure there is at least one track.

An other point about videos:
KPhotoalbum complains it couldn't extract thumbnails. This happened with my 
video and the demo video from Jesper. Just very strange: I got pretty 
previews...

Cheers
Reimar

Am Sonntag, 4. Dezember 2016, 21:40:20 CET schrieb Reimar Imhof:
> Hi Johannes,
> 
> you're right, the length gets printed twice.
> 
> It doesn't happen for the example video from jesper.
> 
> In the ffprobe output I provided you see, there are three streams in my
> video: video, audio and subtitle.
> 
> I've provided a very simple patch: Just test for list.count()<2 instead of
> ...=2.
> 
> Cheers,
> Reimar
> 
> Am Sonntag, 4. Dezember 2016, 21:17:11 CET schrieb Johannes Zarl-Zierl:
> > Hi Reimar,
> > 
> > On Sonntag, 4. Dezember 2016 20:47:19 CET Reimar Imhof wrote:
> > > a new problem with extracting video length:
> > > Message is:
> > > 
> > > Unable to parse video length from ffprobe output! Output was:
> > >  "19.680000\n19.680000\n"
> > 
> > Does ffprobe print the length twice when called like that:
> > ffprobe -v error -select_streams v:0  -show_entries stream=duration -of
> > default=noprint_wrappers=1:nokey=1 '/home/xx/images/abc/xyz.MTS'
> > 
> > ... and does this happen for all your videos?
> > 
> > Cheers,
> > 
> >   Johannes
> > 
> > _______________________________________________
> > KPhotoAlbum mailing list
> > KPhotoAlbum at mail.kdab.com
> > https://mail.kdab.com/mailman/listinfo/kphotoalbum




More information about the KPhotoAlbum mailing list