[KPhotoAlbum] Upgrade totally broken on my computer

Joe josephj at main.nc.us
Wed Feb 18 13:06:20 CET 2015


Just disabled the ppa and reinstalled. Now, I have KPA 4.4 running (I
had 4.5 before.) Way better than nothing!

Next I re-enabled the ppa and tried to do an upgrade in Muon and got a
really weird error panel

Joe

On 02/18/2015 06:30 AM, Joe wrote:
> The latest KPA wouldn't upgrade on my computer, so I purged it after
> running the metadata backup script.
>
> I've been happily using KPA for years. I have over 30k photos of which
> over 7k are tagged.
>
> Now it won't install at all.
>
> The error messages say things about broken packages being held back.
> One of the messages mentions digikam which is *not* installed on my system.
>
> How do I fix this? !!!
>
> Before, I couldn't do the upgrade. Now, i can't use the package at all.
>
> bigbird at ramdass:~$ kphotoalbum
> The program 'kphotoalbum' is currently not installed. You can install it
> by typing:
> sudo apt-get install kphotoalbum
> bigbird at ramdass:~$
>
> I'm not panicking yet ....
>
> Joe
>
> Details:
>
> Toshiba Satellite Notebook with i5 processor
> Kubuntu Trusty (14.04) 64 bit with KPA ppa installed and backports repo
> enabled
> (see attached screenshot of Muon Sources)
>
> KDE 4.14.2
>
> Messages:
>
> Plain install attempt:
>
> bigbird at ramdass:~/backups/20150218-053951$ sudo apt-get install kphotoalbum
> [sudo] password for bigbird:
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  kphotoalbum : Depends: libkgeomap2 (>= 1.0~digikam4.7.0) but it is not
> going to be installed
>                Recommends: kipi-plugins (>= 4:4.7.0) but it is not going
> to be installed
> E: Unable to correct problems, you have held broken packages.
> bigbird at ramdass:~/backups/20150218-053951$
>
> Lovely dependency hell! Haven't been here for quite some time - and
> don't miss it!
>
> First, try one level back:
>
> bigbird at ramdass:~/backups/20150218-053951$ sudo apt-get install libkgeomap2
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  libkgeomap2 : Depends: libmarblewidget18 (>= 4:4.9.90) but it is not
> going to be installed
> E: Unable to correct problems, you have held broken packages.
>
> Try peeling another layer off the onion:
>
> bigbird at ramdass:~/backups/20150218-053951$ sudo apt-get install
> libmarblewidget18
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  libmarblewidget18 : Depends: libastro1 (= 4:4.13.3-0ubuntu0.1) but
> 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 is to be installed
>                      Recommends: marble-plugins (= 4:4.13.3-0ubuntu0.1)
> but 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1 is to be installed
> E: Unable to correct problems, you have held broken packages.
>
> Let apt try to fix things:
>
> bigbird at ramdass:~/backups/20150218-053951$ sudo apt-get -f install
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> The following packages were automatically installed and are no longer
> required:
>   libkgeomap-data libkgeomap1
> Use 'apt-get autoremove' to remove them.
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> bigbird at ramdass:~/backups/20150218-053951$
>
>
>
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at mail.kdab.com
> https://mail.kdab.com/mailman/listinfo/kphotoalbum

-------------- next part --------------
A non-text attachment was scrubbed...
Name: KPA_PPA1.png
Type: image/png
Size: 31013 bytes
Desc: not available
URL: <http://mail.kdab.com/pipermail/kphotoalbum/attachments/20150218/f120d256/attachment-0001.png>


More information about the KPhotoAlbum mailing list