[KPhotoAlbum] EXIF DB questions

Johannes Zarl-Zierl johannes at zarl-zierl.at
Sun Aug 30 01:48:39 CEST 2015


On Saturday 29 August 2015 16:57:29 Tobias Leupold wrote:
> > Can you show me the output of the following commands?
> > 
> > sqlite3 exif-info.db 'select * from settings;'
> 
> DBVersion|2

The current git master uses DBVersion 3, the difference to version 2 being the 
Exif_Photo_LensModel column.

> 
> > sqlite3 exif-info.db .schema
> 
> CREATE TABLE settings (keyword TEXT PRIMARY KEY, value TEXT) without rowid;
> CREATE TABLE exif (filename string PRIMARY KEY, Exif_Photo_FocalLength
> float, Exif_Photo_ExposureTime float, Exif_Photo_ApertureValue float,
> Exif_Photo_FNumber float, Exif_Photo_Flash int, Exif_Photo_Contrast int,
> Exif_Photo_Sharpness int, Exif_Photo_Saturation int, Exif_Image_Orientation
> int, Exif_Photo_MeteringMode int, Exif_Photo_ISOSpeedRatings int,
> Exif_Photo_ExposureProgram int, Exif_Image_Make string, Exif_Image_Model
> string, Exif_GPSInfo_GPSVersionID int, Exif_GPSInfo_GPSAltitude float,
> Exif_GPSInfo_GPSAltitudeRef int, Exif_GPSInfo_GPSMeasureMode string,
> Exif_GPSInfo_GPSDOP float, Exif_GPSInfo_GPSImgDirection float,
> Exif_GPSInfo_GPSLatitude float, Exif_GPSInfo_GPSLatitudeRef string,
> Exif_GPSInfo_GPSLongitude float, Exif_GPSInfo_GPSLongitudeRef string,
> Exif_GPSInfo_GPSTimeStamp float , Exif_Photo_LensModel string);

Your exif db already has the lens model column. I just realized that this is a 
problem in the upgrade routine. The schema update fails to update the 
DBVersion field.

You can try fixing this discrepancy manually for now:
sqlite4 exif-info.db "update settings set value = '3' where keyword = 
'DBVersion';"


> 
> > Maybe you have filenames that are somehow interpreted as being the same
> > when you use the c locale. I guess this doesn't happen with a locale of
> > en_US.utf8?
> 
> With LC_ALL=en_US.utf8, this does not happen, but the UI is still German ...
> > Maybe you can get a more descriptive error message using sqlite. Can you
> > try running some queries (e.g. 'select filename from exif;') using the C
> > locale with sqlite? Maybe the sqlite client prints a more detailed error
> > message containing the keys that are deemed not unique...
> 
> With "select filename from exif;", I get the very same output, no matter if
> I use my normal locale or C. Anway, it seems to be only a small subset of
> my images in the EXIF db, I only get 897 entries, but I have 8521 images
> ...
> 
> Well, could it be that my EXIF db is abit messed up? I'm using git master
> KPA for my real collection if I mess with it ...

Seems like it. It would be normal if the number of entries differed a little 
(video files, other image files that are not parsable by exiv2), but not by 
such a large margin.

  Johannes


More information about the KPhotoAlbum mailing list