[KPhotoAlbum] Segfault when opening search window

Johannes Zarl johannes at zarl.at
Fri Apr 10 18:35:10 CEST 2015


Hi,

Sorry for the late reply.

Assuming this comes from marble you should definitely report a bug for marble 
in the Mint bug-tracker.

As a workaround, it should be sufficient to disable the map widget in the 
dialog, if this is possible before KPA crashes:
(1) Open the annotation dialog (or the search dialog)
(2) Disable the Map widget under Options | Configure window layout...
(3) Save the window setup under Options | Configure window layout...

After this, the map widget should not be loaded anymore when you open the 
search window.

The other option would be to compile KPhotoAlbum with the cmake option 
"WITH_Marble" set to off. You'd have to recompile KPA for this, though...

HTH,
  Johannes

On Sunday 05 April 2015 01:01:58 Harald Barth wrote:
> * Mint 17.1
> 
> * Kphotoalbum 4.6.1 from the PPA
> * Kphotoalbum started OK and build thumbnails a long time
> * Watching thumbnail view OK
> 
> Now:
> 
> * Kphotoalbum starts and I open the search dialog. While still in the
>   search dialog, without touching anything Kphotoalbum goes into a
>   run-away RAM situation (consumes >16GB including all swap) and
>   crashes with segfault. There might have been a dialog box which was
>   started to draw but not completed because of the segfault.
>   See stack trace below
> 
> * It is reproducable and the message is
>   "Errors occured while parsing the .pn2 file!"
>   This messages seems to come from pn2runner?????
>   But this time no stack trace in KDE Crash handler.
> 
> Not completely happy about this behaviour.
> 
> If this is a memory leak in pn2runner/marble, can I disable marble
> (what does it add to kphotoalbum?)
> 
> Harald.



More information about the KPhotoAlbum mailing list