[KPhotoAlbum] libkface

Tobias Leupold tobias.leupold at web.de
Sun Oct 12 01:30:39 CEST 2014


> Apparently the libkface on my system is recognized as 3.4:
> 
> CMake Warning at CMakeLists.txt:93 (find_package):
>   Could not find a package configuration file provided by "Kface" (requested
>   version 3.4.0) with any of the following names:
> 
>     KfaceConfig.cmake
>     kface-config.cmake
> 
>   Add the installation prefix of "Kface" to CMAKE_PREFIX_PATH or set
>   "Kface_DIR" to a directory containing one of the above files.  If "Kface"
>   provides a separate development package or SDK, be sure it has been
>   installed.
> 
> -- checking for module 'libkface>=3.4.0'
> --   found libkface, version 3.4.0

Okay, then I think this is a problem with the CMakeLists definition. If the 
requested version is not found, the KFACE_FOUND variable should not be set, 
causing all this not being built (and thus avoiding the errors).

I fear this out of my skills ... perhaps someone coding C++ longer than six 
months can help here (Johannes?! ;-)

Anyways, we definitely have to fix this before the next release is done.


More information about the KPhotoAlbum mailing list