[KPhotoAlbum] People and Locations categories not loaded anymore

Christoph Moseler forums at moseler.net
Wed Nov 26 22:54:24 CET 2014


Hi all,

it seems, that commit e7acc71a7abc4573653cedafbc514357971e9d47 breaks 
loading the both categories People and Locations.
With 0eac65a931721c2373b95b5a49de20eee06be362 these both categories are 
loaded.

To reproduce I created a minimalistic index.xml. If I load this with 
commit e7ac... and click on "Places" there are 2 images assigned to 
"None", with the commit before, Berlin and Munich are assigned to 1 
image each.

Is it possible that the speed optimized index.xml that I am using is not 
converted correctly while migrating the old "standard"-categories?

Christoph


<?xml version="1.0" encoding="UTF-8"?>
<KPhotoAlbum version="5" compressed="1">
     <Categories>
         <Category name="Locations" icon="applications-internet" 
show="1" viewtype="1" thumbnailsize="32" positionable="0">
             <value value="Berlin" id="1"/>
             <value value="Munich" id="2"/>
         </Category>
         <Category name="Folder" icon="folder" show="0" viewtype="0" 
thumbnailsize="32" positionable="0"/>
         <Category name="Media Type" icon="video" show="0" viewtype="0" 
thumbnailsize="32" positionable="0"/>
     </Categories>
     <images>
         <image file="1.jpg" label="0805106186" 
startDate="2008-05-10T13:44:51" endDate="2008-05-10T13:44:51" angle="0" 
md5sum="00273ab34b2b2755a6eed480c7d04a16" width="3072" height="2048" 
Locations="1"/>
         <image file="2.jpg" label="0805106186" 
startDate="2008-05-10T13:44:51" endDate="2008-05-10T13:44:51" angle="0" 
md5sum="00273ab34b2b2755a6eed480c7d04a16" width="3072" height="2048" 
Locations="2"/>
     </images>
     <blocklist/>
     <member-groups>
     </member-groups>
</KPhotoAlbum>



More information about the KPhotoAlbum mailing list