[KPhotoAlbum] Nef files not displaying embedded jpeg any more?

Timothee Groleau kde at timotheegroleau.com
Sat Oct 27 17:05:10 CEST 2012


Thanks Miika and Jan,

OK, erm, false alarm, this is embarrassing: my build was not linked to 
libkdcraw at all. I suppose cmake must had told me the lib wasn't found, 
but I didn't see it. I assumed (incorrectly) that kphotoalbum would 
refuse to build if libkdcraw wasn't there.

So anyway, "sudo apt-get install libkdcraw-dev", clean cmake, make, and 
voila, it works again! My apologies for the noise :$ .

I really do miss the ability to recreate thumbnails though. After my 
initial linkage blunder, some of the thumbnails in my display are from 
the tiny 160x120 thumbnails, and I'd like to change them back to 
something nicer :/

Thanks again,
Tim.





On 27/10/2012 20:02, Jan Kundrát wrote:
> On Saturday, 27 October 2012 04:15:37 CEST, Timothee Groleau wrote:
>> I've just installed 4.3 from source and I've noticed my nikon nef 
>> files don't display the large embedded jpeg files any more 
>> (4352x2868, SUBIFD#0). Instead they show the small thumbnail 
>> (160x120, IFD#0), which is unusable. The feature was working fine at 
>> Kphotoalbum 4.1.1. Is that an expected change? I've also tried the 
>> latest git sources, and had the same result.
>
> Weird -- I cannot explain how come that this has changed for you since 
> 4.1.1.
>
> What I do have to say, though, is that there's been a bug for RAW file 
> loading present since the time I switched KPA to use kdcraw many years 
> ago; I've fixed that in a local commit on 1st October, but forgot to 
> push. I've now fixed that, so I'm interested to know whether the last 
> git works for you.
>
> Cheers,
> Jan
>



More information about the KPhotoAlbum mailing list