[KPhotoAlbum] Searching within folders in KPA 4.3

Joe josephj at main.nc.us
Sun Oct 21 10:39:24 CEST 2012


Thanks.  Replies inline.

Joe

On 10/21/2012 02:52 AM, Miika Turkia wrote:
> On Sun, Oct 21, 2012 at 5:57 AM, Joe <josephj at main.nc.us> wrote:
>> I'm very behind in tagging my photos.  My photos are stored in folders
>> named by the date of the most recent picture in the folder.  I try to
>> keep them in batches of 700 or less per folder.
>>
>> To catch up, I'm trying to tag the newest ones first.
>>
>> What I did was select Folder from the main KPA window and then select a
>> folder to work on.  That works fine, but when I try to search within
>> that folder (nested searches seem to work great everywhere else), it
>> reverts to matching against my entire collection instead of a smaller
>> +subset of the folder.
>>
>> I have a Category/tag named Done for pictures which are completely
>> tagged.  What I wanted to do was select all the photos in the folder
>> that are *not* Done.  This does not appear to work as I expected.
>>
>> I know I can work around this by manually entering a date range or just
>> sorting the images in reverse date order, but it would be nice (and
>> consistent) if sub-selections of a folder would work.
> Search for the tag first and then go select the folder. The search
> seems to start from the whole image database and not to narrow down
> the current selection. You could also configure the "Untagged Images"
> feature to use your Done tag and thus you could select the untagged
> images from main window (the main window "icons" narrow down the
> current selection).
I tried the search that way and it works. When you go to Folders,
folders that don't have any matching pictures just disappear.  It's a
bit strange to think of it that way, but it does work.

As for the Untagged Images feature:  The way I understand it is that
whenever you load new pictures, the untagged field gets set to
untagged.  Whenever you tag items an+d press Done, that flag gets
cleared automatically.  I know I can use Continue Later instead of Done
and it will leave the flag set, but I click Done most of the time by bad
habit because I didn't know what Continue Later was for until recently. 
I do have an untagged keyword associated with the feature, but I prefer
having a "Done" that has to be set manually so it's a lot less likely to
get set by accident.  Someone on this list showed me this method some
time ago.
>> Am I doing something wrong, or is this a bug?
> I would call this a feature as it is consistent for the search
> function to always affect the whole database.
>
> I would be happy if the search was to the current selection instead
> the whole image database. Clicking the home button before the search
> to achieve current functionality is easy enough but search to narrow
> down current selection cannot be done with current implementation.
Thanks for checking.

That's a little hard to understand.  I'm not really sure how searching
works, but I just searched for Animal (Category) = Deer and then
subsequently searched for Animal=Bluejay.  I was expecting an "and"
operation which would only show me pictures that had both animals in
them, but apparently got an "or" operation - now having all the pictures
displaying either animal.  In any case, the first search results weren't
replaced by the results of the second one.   The second one just added
to the first, so in some way searches are cumulative and don't start
with a clean slate - at least in what finally gets selected.

Eventually, I'll have to "git with the program" and start compiling new
versions.  I know the instructions have been posted on this list several
times.


> miika


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kdab.com/pipermail/kphotoalbum/attachments/20121021/7130226c/attachment.html>


More information about the KPhotoAlbum mailing list