[KPhotoAlbum] KPhotoAlbum Crashes when viewing thumbnails

Murray Strome wmstrome at yahoo.com
Fri Jun 17 17:29:28 CEST 2011


It did not work. I changed the line as you suggested to install in /opt and got this set of errors:

mkdir: cannot create directory `/opt/kpa': Permission denied
mkdir: cannot create directory `/opt/kpa': Permission denied
/home/murray/Downloads/git-compile-tmp.sh: line 28: cd: /opt/kpa: No such file or directory
Cloning into kphotoalbum...
remote: Counting objects: 25165, done.
remote: Compressing objects: 100% (4774/4774), done.
remote: Total 25165 (delta 20621), reused 24786 (delta 20334)
Receiving objects: 100% (25165/25165), 31.47 MiB | 542 KiB/s, done.
Resolving deltas: 100% (20621/20621), done.
/home/murray/Downloads/git-compile-tmp.sh: line 32: cd: /opt/kpa/kphotoalbum: No such file or directory
CMake Error: The source directory "/home/murray/Documents" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make: *** No rule to make target `install'.  Stop.


I then manually changed the permissions for /opt and tried again and got this:

~/Downloads/git-compile-tmp.sh
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
git is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Cloning into kphotoalbum...
remote: Counting objects: 25165, done.
remote: Compressing objects: 100% (4774/4774), done.
error: inflate: data stream error (incorrect data check)iB/s   
fatal: pack has bad object at offset 17527321: inflate returned -3
fatal: index-pack failed
/home/murray/Downloads/git-compile-tmp.sh: line 32: cd: /opt/kpa/kphotoalbum: No such file or directory
CMake Error: The source directory "/opt/kpa" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make: *** No rule to make target `install'.  Stop.


What have I missed?

Murray
--- On Fri, 6/17/11, Miika Turkia <miika.turkia at gmail.com> wrote:

From: Miika Turkia <miika.turkia at gmail.com>
Subject: Re: [KPhotoAlbum] KPhotoAlbum Crashes when viewing thumbnails
To: "Murray Strome" <wmstrome at yahoo.com>
Cc: "Andreas Neustifter" <andreas.neustifter at gmail.com>, kphotoalbum at kdab.com
Received: Friday, June 17, 2011, 5:20 AM

Hello Murray,

sorry for the late replay, I am currently waiting for transit back home. I've been disconnected for almost three weeks ;)

What you need to do is make the script executable and run it. Location does not matter, you can try it out from ~/Downloads. You can run the script as normal user. It uses sudo to install a few required packages (and sudo asks for your password while running). Then it downloads the source code, compiles and installs. Official version can still be accessed the same way as before and the new version needs the full path.


I personally compile my own KPA under /opt and would recommend that to you (the script does not use sudo for installing so that is one thing that needs tweaking, I have /opt/kpa directory owned by myself so I don't need extra privileges for the sources or installation). At least if the development version fixes your problem.


There is no need to run kphotoalbum as root...

So the needed steps are more or less the following:
- chmod 755 ~/Download/git-compile-tmp.sh
- ~/Download/git-compile-tmp.sh (give password for the sudo to install compile dependencies)

- /tmp/kpa/kde4-install/bin/kphotoalbum -c ~/Pictures/index.xml

Or if you want it under /opt, change first the MY_KDE_SRC variable within the git-compile-tmp.sh from /tmp/kpa to /opt/kpa

If there is still something open, I should be a bit more responsive once back home.


miika

On Sat, Jun 4, 2011 at 1:10 PM, Murray Strome <wmstrome at yahoo.com> wrote:

Hi Milika,

I am finally home and about to try the file you sent me. I am not very adept at compiling etc. so I would appreciate it if you could give me (or point me to) some simple instructions as to how to do this. In particular. My current version is in: /usr/bin/kphotoalbum


So, where should I extract the file? Do you recomment ~/tmp or /tmp? (or /opt?). Do I need to run it as root (i.e. sudo  /tmp/kpa/kde4-install/bin/kphotoalbum -c <picturepath>/index.xml). Right now, the file is in ~/Downloads. I assume that I will need to make it executable. Is that correct?


I have upgraded my LINUX on one machine to Kubuntu 11.04. I thought it was working OK, but after a while it still crashed. 

Thanks for your help.

Murray

--- On Sat, 5/21/11, Miika Turkia <miika.turkia at gmail.com>
 wrote:

From: Miika Turkia <miika.turkia at gmail.com>

Subject: Re: [KPhotoAlbum] KPhotoAlbum Crashes when viewing thumbnails
To: "Murray Strome" <wmstrome at yahoo.com>
Cc: "Andreas Neustifter" <andreas.neustifter at gmail.com>, kphotoalbum at kdab.com

Received: Saturday, May 21, 2011, 6:06 A

Hello,

there is a bugfix in the development version of KPA that is not included in the "stock" version of Ubuntu's kphotoalbum. Applied on 2010-12-22 and it fixes some exif related crashes. This might well be the bug you are hitting.



Unfortunately I do not currently know any other way to make sure than compiling KPA yourself from the development version. (Attached script grabs the current source from git and compiles it. Everything is done under /tmp but I myself use /opt instead. Note that the KPA compiled like this does not find your current image dir without aid as the KDEHOME is under /tmp. Run as follows if you want to give it a try: /tmp/kpa/kde4-install/bin/kphotoalbum -c <picturepath>/index.xml)



HTH,
theBro




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kdab.com/pipermail/kphotoalbum/attachments/20110617/d746c741/attachment.html>


More information about the KPhotoAlbum mailing list