[KPhotoAlbum] Warning for insufficient permissions?

Steffen Jost steffenjost at web.de
Sun Dec 4 12:05:54 CET 2011


Should Kphotoalbum issue a warning if Thumb.db cannot be written?

If Kphotoalbum is started from a konsole, an error message is written 
there, but it made me wonder why generally not _all_ errors are caught 
and displayed in a pop-up window, rather than being silently ignored?

My Kphotoalbum did not display thumbnails any more, after I upgraded to 
openSUSE 12.1. I read that Kphotoalbum had problems with the thumbnails 
not too long ago, so I tried the suggested remedies, but it would not 
work. I tried a fresh checkout from git, undoing my changes, but nothing 
helped. Kphotoalbum always generated the thumbnails, but would just not 
display them. Everything else worked, the annotation dialog showed the 
pictures just fine and annotations were remembered.

In the end I found out about it by running Kphotoalbum from a konsole 
window, where an error message was displayed that thumbs could not be 
written due to insufficient permissions. I had changed my uid during the 
upgrade, but my pictures are not below my home directory and thus kept 
the old uid - and just the Thumbs.db files were the only ones without 
group writing permissions. This is admittedly a very special and 
unlikely scenario, but it just made me wonder about the question above.

Cheers,
  Steffen.



More information about the KPhotoAlbum mailing list