[KPhotoAlbum] problems with kphotoalbum-20090613.tar.bz2

Jesper K. Pedersen blackie at kde.org
Sun Jun 21 13:43:46 CEST 2009


On Saturday 20 June 2009 09:31:33 Martin Jost wrote:
| Hello,
|
| I tried kphotoalbum-20090613.tar.bz2 but have run into problems.
| (I had 4.0.1 installed in the same location before. Just to let you
| know, if I might need to delete some old config files or some such)
|
| 1.
| On my machine, it didn't compile "out of the box".
| I changed the following two files:
Oh, that function was first introduce in Qt 4.5 Anyway, the count method does 
the same, so I will just use that. Thanks
Please attach patches in the future rather than post them inline in the email, 
as that runs the risk of line breaking which will make the patch command barf 
at me.

| 2.
| Now it starts, and yes the starting screen looks good.
| Even better is, that the folder view starts out with all branches
| closed. (I was thinking about adding a wishlist item for that - now I
| already got it, even 6 months before christmas :-)
| IHMO even better would be, if KPA could remember the state of the
| branches at program exit...
Indeed, and I looked into that a lot but did unfortunately not find a way to 
even do this when just narrowing using the line edit at the top of the window
|
| 3.
| BUT...
| I clicked on one of the folders (containing 524 images according to KPA)
| I just get back to the opening screen. (See attached screenshot)
| This seems to be updated. The breadcrumb (lower left) shows the selected
| folder.
| The status (lower right) shows the correct count of images in the folder
| (524) But the date-bar only shows 509 (?)
Did some of the images contain any dates outsite the visible (for the datebar 
view) interval? Maybe some of the images had invalid dates?


| But that's it - no image visible...
I'm not sure what that line meant, did you not see any images when you click 
show images?

| Also searching for locations, persons etc. behaved the same way. No
| images visible, instead I just get back to an updated main screen.
Hmm that is how KPA works, no? While narrowing in on the image you wanna see, 
you click the category you wanna see, then the item of that category, then the 
category, then item, and finally you press "show images"

| If I now click "Run slideshow", it shows the fotos I would expect.
| But I never were able to see the "usual" thumbnail view.
|
| What am I doing wrong here ?
Did you click on the "show images" item in the browser?

| 4.
| EXIF DB still doesn't work.
| I recreated the DB, but I still see errors on the console.
Ouch. Anyone who can help here?

| (This is from a new start of KPA, after the DB was rebuild)
| And a query with the default settings of the dialog yielded 0 images.
| ---------------------------------------------------------------
| godot:/images/fotos/2009/Wien> /usr/local/bin/kphotoalbum
| 2005/Christof/15.jpg already in database
| 2005/Christof/15.jpg already in database
| 2005/Christof/22.jpg already in database
| 2005/Christof/22.jpg already in database
| 2005/Christof/25.jpg already in database
| 2005/Christof/25.jpg already in database
| 2005/Christof/28.jpg already in database
| 2005/Christof/28.jpg already in database
| 2005/Christof/26.jpg already in database
| 2005/Christof/26.jpg already in database
| 2005/Christof/56.jpg already in database
| 2005/Christof/56.jpg already in database
| 2005/Christof/64.jpg already in database
| 2005/Christof/64.jpg already in database
| 2005/Christof/67.jpg already in database
| 2005/Christof/67.jpg already in database
| 2005/Christof/60.jpg already in database
| 2005/Christof/60.jpg already in database
| 2005/Christof/69.jpg already in database
| 2005/Christof/69.jpg already in database
| 2006/Norwegen/19.8./IMG_0500.JPG already in database
| 2006/Norwegen/19.8./IMG_0512.JPG already in database
| 2006/Norwegen/19.8./IMG_0540.JPG already in database
| 2006/Norwegen/19.8./IMG_0623.JPG already in database
| 2006/Norwegen/19.8./IMG_0628.JPG already in database
| 2006/Norwegen/22.8./IMG_0995.JPG already in database
| 2006/Norwegen/23.8./IMG_1081.JPG already in database
| 2006/Norwegen/24.8./IMG_1265.JPG already in database
| 2006/Norwegen/24.8./IMG_1358.JPG already in database
| 2006/Norwegen/25.8./IMG_1443.JPG already in database
| 2006/Norwegen/25.8./IMG_1444.JPG already in database
| 2006/Norwegen/27.8./IMG_1580.JPG already in database
| 2006/FDS/75 Jahre Taborkirche/IMG_2753.JPG already in database
| 2006/Donautal/IMG_2862.JPG already in database
| Error running query: INSERT into exif values (?, ?, ?, ?, ?, ?, ?, ?, ?,
| ?, ?, ?, ?, ?, ?)
| Error was:  Parameter count mismatch
| Error running query: INSERT into exif values (?, ?, ?, ?, ?, ?, ?, ?, ?,
| ?, ?, ?, ?, ?, ?)
| Error was:  Parameter count mismatch
| Error running query: INSERT into exif values (?, ?, ?, ?, ?, ?, ?, ?, ?,
| ?, ?, ?, ?, ?, ?)
| Error was:  Parameter count mismatch
| Error running query: INSERT into exif values (?, ?, ?, ?, ?, ?, ?, ?, ?,
| ?, ?, ?, ?, ?, ?)
| Error was:  Parameter count mismatch
| Error running query: SELECT DISTINCT Exif_Image_Make, Exif_Image_Model
| FROM exif
| Error was: No query Unable to fetch row
| Error running query: SELECT filename from exif WHERE (0 <=
| Exif_Photo_FocalLength and Exif_Photo_FocalLength <= 10100)
| Error was: No query Unable to fetch row
| QSqlDatabasePrivate::removeDatabase: connection 'exif' is still in use,
| all queries will cease to work.
| ---------------------------------------------------------------
|
| Regards
|
| Martin

-- 
Having trouble finding a given image in your collection containing
thousands of images?

http://www.kphotoalbum.org might be the answer.



More information about the KPhotoAlbum mailing list