[KPhotoAlbum] error while executing the SQL backend command

Thomas Pircher tehpeh at gmx.net
Sat Jun 6 12:08:24 CEST 2009


Hi there,

first of all: thanks for Kphotoalbum, it is a very useful tool. It does exactly 
what I was looking for: it helps me to organise my pictures in a very effective 
way! Thanks for your work guys!


After upgrading to KDE4 (and to Kphotoalbum 4.0.1) I have this error message 
which pops up every time I add new pictures to my image gallery:

--- snip ---
There was an error while executing the SQL backend command. The error is 
likely due to a broken database file.
To fix this problem run Maintainance->Rebuild EXIF database.

For debugging, this is the command I tried to execute:
INSERT into exif values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
This was the error message I got:
constraint failed Unable to fetch row
--- snap ---

I think I get one of these messages for each new image. I have tried many 
times to rebuild the EXIF database, to delete exif-info.db, remove the 
.thumbnails folder, without success. How can I fix this?

My system is:
Debian Linux testing (on amd64)
Kphotoalbum Version 4.0.1 Using KDE 4.2.2 (KDE 4.2.2)

Cheers
Thomas


More information about the KPhotoAlbum mailing list