[KPhotoAlbum] kphotoalbum crashes

costal martignier 07.09 at martignier.net
Sat Jul 25 19:22:35 CEST 2009


it's so crazy...

i checked and debugged and tested hours now, recompiled KPA, tested all
index.xml on many computers, and checked teh file over and over again....

then i wrote my mail to the list, checked once again the index file after that
and found the error in the file, there was a duplicate category entry:

  <Category icon="" viewtype="0" thumbnailsize="64" name="spezielles" show="1" >
   <value value="pflanze" id="1" />
   <value value="balkon" id="2" />
  </Category>
  <Category icon="" viewtype="0" thumbnailsize="64" name="spezielles" show="1" >
   <value value="pflanze" id="1" />
   <value value="balkon" id="2" />
  </Category>


i have absolutley no clue why this happened, it must be a bug or something
other!?

i delete one entry, and it works now without a problem...

anyone knows something about this problem/bug?

i lost some hours now, but i'm happy again :)

wish you all a nice weekend...

costal


costal martignier <07.09 at martignier.net> hat am 25. Juli 2009 um 19:02
geschrieben:

> hi all,
> 
> i have a strange problem here, KPA crashes on start.
> i worked some time with it and tagged some images.
> then i had a systemcrash and after that KPA doesn't start with the index.xml
> file, also all backups of the index.xml don't work...
> 
> if i start i recreate teh index file from scratch, KPA starts normaly.
> 
> i get the following crashreport:
> 
> Application: KPhotoAlbum (kphotoalbum), signal SIGABRT
>  
> Thread 1 (Thread 0xb549e700 (LWP 13513)):
> [KCrash Handler]
> #6 0xb7ff6430 in __kernel_vsyscall ()
> #7 0xb5ed36d0 in raise () from /lib/tls/i686/cmov/libc.so.6
> #8 0xb5ed5098 in abort () from /lib/tls/i686/cmov/libc.so.6
> #9 0xb6195595 in qt_message_output () from /usr/lib/libQtCore.so.4
> #10 0xb6195681 in qFatal () from /usr/lib/libQtCore.so.4
> #11 0xb6195775 in qt_assert () from /usr/lib/libQtCore.so.4
> #12 0x080b9c7a in XMLDB::FileReader::loadCategories (this=0xbfc11d80,
> elm=@0xbfc11d28) at
> /usr/local/src/kphotoalbum-20090711/XMLDB/FileReader.cpp:156
> #13 0x080bd375 in XMLDB::FileReader::read (this=0xbfc11d80,
> configFile=@0xbfc11ef0) at
> /usr/local/src/kphotoalbum-20090711/XMLDB/FileReader.cpp:50
> #14 0x080ad75e in Database (this=0x9bd1c90, configFile=@0xbfc11ef0) at
> /usr/local/src/kphotoalbum-20090711/XMLDB/Database.cpp:51
> #15 0x08151c3e in DB::ImageDB::setupXMLDB (configFile=@0xbfc11ef0) at
> /usr/local/src/kphotoalbum-20090711/DB/ImageDB.cpp:54
> #16 0x08124e6f in MainWindow::Window::load (this=0x9b70f08) at
> /usr/local/src/kphotoalbum-20090711/MainWindow/Window.cpp:1021
> #17 0x08125dfd in Window (this=0x9b70f08, parent=0x0) at
> /usr/local/src/kphotoalbum-20090711/MainWindow/Window.cpp:140
> #18 0x0807c5ca in main (argc=1, argv=0xbfc121e4) at
> /usr/local/src/kphotoalbum-20090711/main.cpp:78
>  
> 
> 
> 
> but afaik this only tells us there is a problem with reading the indexfile?!?
> 
> i've uploaded one off the index files: http://martignier.net/13.zip
> 
> would be great if someone has an idea what the problem could be.
> 
> thanks and best regards
> costal
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at kdab.net
> http://mail.kdab.net/mailman/listinfo/kphotoalbum


More information about the KPhotoAlbum mailing list