[KPhotoAlbum] Compiling recent KPhotoAlbum for Debian Lenny

theBro thebro at luukku.com
Thu Aug 6 06:41:30 CEST 2009


Hello Matthias,

you might want to try compiling KPA "the old way". Attached script downloads recent versions from svn and compiles them. It grabs also some current KDE stuff, including kdcraw. (I haven't tested on Debian but used to work on old Ubuntu so should work in Lenny also.)

I think the icons KPA uses are mostly standard KDE icons and are thus not shipped with KPA. 

theBro

Matthias Heukäufer kirjoitti 05.08.2009 kello 23:10:
> Hi!
> 
> I am currently trying to compile a recent version of KPhotoalbum
>  (snapshot 
> 20090721 and/ or the SVN-version) for Debian Lenny.
> The first thing I stumbled upon while compiling the latest snapshot
>  was the 
> compiler error about the Qt4.4/4.5 issue that Martin Jost has mentioned 
> already. I recommend to replace the snapshot with another one that
>  builds 
> without any errors, as it might leave a bad impression on people who
>  have 
> never worked with KPhotoAlbum before.
> Applying Jesper's patch or using a svn-checkout results in a clean
>  build.
> That 
> can be started without problems. Most of my images are not displayed,
> though, 
> to be more exact all the images that are not jpg.  Cmake had complained 
> about "libkdcaw release < 0.2.0, too old" and "libkipi release <
>  0.2.0, too 
> old". While I could probably live without kipi for a while, dcraw is
>  really 
> essential for me, as I am shooting raw pictures most of the time.
> Unfortunately, backports.org does not provide any more recent
>  packages of 
> those libraries, and when I tried to compile them myself using the
>  debian 
> source-package "kdegraphics", I was confronted with a large number
>  of unmet 
> dependencies.
> Does anybody have any suggestions on how to get KPhotoAlbum running on
> Debian 
> stable?
> On a side note: I do not see any icons either on the main screen or in 
> dialogs. Buttons that should show a graphic on them are just empty. I
> suspect 
> that it results from running a KDE4-app in KDE 3.5.10. Is there any
> solution 
> for it (Yes, I have exported "KDEDIRS=~/kphotoalbum".)?
> 
> Thanks for your help - Matthias
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at kdab.net
> http://mail.kdab.net/mailman/listinfo/kphotoalbum


....................................................................
Luukku Plus -paketilla pääset eroon tila- ja turvallisuusongelmista.
Hanki Luukku Plus ja helpotat elämääsi. http://www.mtv3.fi/luukku
-------------- next part --------------
A non-text attachment was scrubbed...
Name: svn-compile.sh
Type: text/x-sh
Size: 1739 bytes
Desc: not available
Url : /mailman/pipermail/kphotoalbum/attachments/20090806/b0663158/attachment.bin 


More information about the KPhotoAlbum mailing list