[KPhotoAlbum] Gentoo setup help

Ted Miller limaohio123-CompMailLists at yahoo.com
Mon Nov 24 03:28:38 CET 2008


I am trying to get version 3.1.1 set up on Gentoo.  I have kphotoalbum 
running, but it is more like limping.

1. It does not seem to be able to view 48 bit tiff images.  They all show 
up as gray squares with the missing upper-right corner.  I have found the 
following:
media-libs/tiff-3.8.2-r4 is installed
KView reports "Unknown image format" in the status bar
cinepaint opens them
krita opens them
gimp did not open them  (or even list tif as an image file)
On my Centos 5 installation gimp opens them (with a warning about 
truncating them down to 8 bit), KView opens them, and kphotoalbum 3.0 shows 
them all just fine.


I am also stuck on getting some of the dead things in "Feature Status" working:

2. EXIF support is not working.  I installed kde-gfx/exiv2-0.17 and 
media-libs/libkexiv2-0.1.5.

3. SQLite database support is not working.  I installed 
dev-db/sqlite-3.5.9.  Do I need the "embedded" USE tag, or is something 
else wrong?

4. "Video Thumbnail support" is not working.  I installed 
kde-base/artsplugin-xine.

I hope someone who uses Gentoo reads this list, as that would be most 
helpful.  I am just getting started with Gentoo, setting it up as my image 
manipulation environment, after frustrations getting Centos and Fedora to 
support the various programs I want to use.  So far it seems to be working 
OK, but I would like to resolve these issues, and have it working really well.

Thank you for your time,
Ted Miller
Indiana, USA


More information about the KPhotoAlbum mailing list