[KPhotoAlbum] Bug in KPA 3.0

Jesper K. Pedersen blackie at kde.org
Mon Apr 7 09:17:04 CEST 2008


The only reason I can see for this is that your md5 was broken.
When KPA is searching for new images it will compare their md5's with whats in 
the DB, and if it sees that it matches one of those in the DB, then it will 
check if the one in the DB still exists on disk, if not, it will copy its 
annotations over.

To remove the dead icons of yours now, simply run maintainance->find images 
not on disk, and delete them.

Cheers
Jesper.

On Monday 07 April 2008, Kimball Robinson wrote:
| This might not be an issue anymore, but I haven't had a chance to compile
| the latest release on ubuntu.
|
| KPA has indexed a bunch of images in a  directory that no longer exists. 
| It has not detected that the dirname changed.  Also, I get tons of
| flickering with blank icons that have the top right corner cut off, in
| those situations. It's liable to give someone a seizure, all that
| flickering.
|
| some/pics/for/kpa/example/directoryThatExists?/image.jpg
| is now at
| some/pics/for/kpa/example/directoryThatExistsQuestionMarkFree/image.jpg
| I have hundreds of images there.  None of them will display, though they
| are all present.
| KPA has reindexed the images that are there, as separate images.  So my
| tags haven't carried over.



-- 
Having trouble finding a given image in your collection containing
thousands of images?

http://www.kphotoalbum.org might be the answer.


More information about the KPhotoAlbum mailing list