[KPhotoAlbum] Bug: View crashes

Risto H. Kurppa risto at kurppa.fi
Fri Sep 14 12:41:07 CEST 2007


talking about this, experiencing w. NEF:s: the image will not be shown
before allvisible thumbs are created.. So jumping to a location in the
thumbnail view, it starts building the thumbs. If they are small, it
takes relatively long. If you immediately open an image w. a
doubleclick or so, the image will not be shown immediately, but it
will first wait to create the rest of the thumbs.


r



2007/9/14, Jan Kundrát <jkt at gentoo.org>:
> Christoph Moseler wrote:
> > DB::ImageDB::instance()->info(_list[ _current]) returns null for
> > filename set to "" (empty string).
> >
> > But I couldn't figure out, why _list[ _current] is empty.
>
> Well, QValueList's documentation is a bit vague on this, but I guess
> that it (at least in this special case) behaves like an associative(!)
> container, where "indexing" (operator[]()) with non-existing key simply
> adds an item to the container, and this item is constructed by its
> default contructor.
>
> Indeed, when using your actions, Viewer::ViewerWidget::currentInfo() is
> called while the _list is still empty.
>
> I've added a check to the MainWindow::Window::launchViewer() that simply
> shows all images in such case. I hope this won't be confusing, because:
>
> a) EXIF search displays a dialog box saying "no images found" if there
> are no matches to the query
> b) browser widget won't let you perform search that would return zero images
>
> And I've added yet another check that runs after the previous one. It is
> necessary because user database might contain no pictures :].
>
> Thanks for reporting,
> -jkt
>
> --
> cd /local/pub && more beer > /dev/mouth
>
>
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at kdab.net
> http://mail.kdab.net/mailman/listinfo/kphotoalbum
>
>
>


-- 
r

--

| risto h. kurppa
| risto at kurppa dot fi
| http://risto.kurppa.fi <-- UUSI / NEW !!


More information about the KPhotoAlbum mailing list