[KPhotoAlbum] Something wrong with metadata updating?

Jan Kundrát jkt at gentoo.org
Tue Oct 23 23:53:40 CEST 2007


Baptiste MATHUS wrote:
> I just tested on the demo db, i've got the same problem.
> When updating a photo label, shouldn't it retrieve the file name?

That depends on your configuration. By default, current version will
read from the file name *only* but earlier versions were trying to use
other Exif/IPTC metadata fields as well. This has been changed back to
what KPA 3.0.2 does in 3.1.0-rc2. Unfortunately, users who tried a SVN
version or 3.1.0-rc1 will have this "improved" configuration by default.

Easy workaround is to remove the "[MetadataSyncing]" section from your
~/.kde/share/config/kphotoalbumrc file.

> On my config (though according to what Jan recently tested, it could be
> the source of the problem :-)), when I do :
> * Maintenance/Re-Read Metadata From Files
> * uncheck every checkbox except the "update label" one (second in the list)
> 
> The retrieved label does not seem to be the photo name :-/. See the
> screenshots :
> * before : http://ehehe.free.fr/kpa/before.png
> * after : http://ehehe.free.fr/kpa/after.png
> 
> Do you have the same behaviour? Is it normal???

In this case, I believe this is correct behavior as the labels in the
demo database are different than corresponding file names. What would
you like to see here? Clearly you can't have two images with the same
file name in one directory. If I'm missing something, please let me know.

Cheers,
-jkt

-- 
cd /local/pub && more beer > /dev/mouth

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : /mailman/pipermail/kphotoalbum/attachments/20071023/f7e0154a/attachment.pgp 


More information about the KPhotoAlbum mailing list