[KPhotoAlbum] KPA 3.1.0 RC1 not importing data / crash on cancel

Jan Kundrát jkt at gentoo.org
Thu Oct 11 00:01:41 CEST 2007


Martin Jost wrote:
> Ok, importing with the photos already present in the target directory
> now works "mostly".
> (All of the above mentioned problems are gone)

As a free bonus, I've introduced a nice segfault when copying files from
the KIM file, which should be fixed in r723822 :).

> There is one problem, which makes it quite useless:
> At startup KPA reads the new images. They are now present in the DB but
> with no tags.
> Reading the .kim files should now add the tags. But instead it leaves
> the original entries untouched and creates new entries.
> If the already present photo has a filename of 'x.jpg' the import
> creates 'x-2.jpg'. So in the end I have twice that much photos in the
> folder (as seen by KPA), one set with the real photo but no tags, a
> second set with a missing photo (grey with the edge snipped off) but the
> correct tags.

OK, this seems like a design choice. From the import dialog:

"Next you must tell KPhotoAlbum in which directory to put the images.
This directory must of course be below the directory root KPhotoAlbum
uses for images. KPhotoAlbum will take care to avoid name clashes."

An easy workaround is to move the original files away, do the import,
move them back (overwriting the imported files) and re-create checksums.
I think this is acceptable. We could add a new checkbox "I know I'm
overwriting files, just do it anyway", but I guess it isn't worth the
effort. Is that fine with you?

Thanks for your cheating, you've helped to fix one bug and improve the
interactivity.

Cheers,
-jkt

-- 
cd /local/pub && more beer > /dev/mouth

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : /mailman/pipermail/kphotoalbum/attachments/20071011/a1a4211c/attachment.pgp 


More information about the KPhotoAlbum mailing list