[KPhotoAlbum] How to make share auto mount on system start

Neil Paisnel neil at paisnel.co.uk
Fri May 4 22:30:01 CEST 2007


I have now got a working share on the windows XP home machine, that I can
access from the Kubuntu Feusty box from within KPA.

I also have an entry in the fstab file

//Su/Pictures /home/pics smbfs user,auto,rw,uid=1000,gid=1000,umask=000    0
0

but on boot this entry does not work.  I have to use 
sudo mount -a

and then the share works.


I read an article somewhere that mentioned that in ubuntu versions 6.10 and
later that there was a problem in the order the startup scripts were run,
and the system tried to mount files before the network was connected.

It recommended using the mv command to move the network startup script in
etc/rcS.d from s40networking to s29networking to start the network script
before the mount fstab script.

Well, I tried that and still no good.

Any ideas on how I can get this mount to work on startup?






More information about the KPhotoAlbum mailing list