[KPhotoAlbum] KPA across network

Neil Paisnel neil at paisnel.co.uk
Tue May 1 09:35:08 CEST 2007


OK, Scott, thanks, that was it.
Smbfs was not there.  Found it with synaptic, and now it does mount.

BUT not with the correct permissions.

If I view the shared folder in directly konqueror, I can read and write to
it.  But viewed in the mounted folder it is not possible to write to, or
create files in the local mounted directory.  
Am trying various options and permissions as found in the man pages, but so
far nothing.


-----Original Message-----
From: Scott Lair [mailto:plair at mailzone.com] 
Sent: 01 May 2007 03:16
To: Neil Paisnel
Subject: Re: [KPhotoAlbum] KPA across network

Two things to try:

1 Do you have mount.smbfs installed? 
try whereis mount.smbfs to make sure

2 run "smbclient -L su"
just hit enter when it asks for password.  This 
will tell you the exact shares available.  You
should  be able to mount one of the file systems here.



Neil Paisnel wrote:
> NO, no joy with that either. 
> I tried
> sudo mount -t smbfs //su/My\ Documents /home/Photos
>  as you suggested, and I also tried mounting shares from the two other XP
> boxes on the network, and different folders on those machines, but the
exact
> same error as before:
> mount: wrong fs type, bad option, bad superblock on //su/My Documents/My
> Pictures,
>        missing codepage or other error
>       In some cases useful info is found in syslog - try
>        dmesg | tail  or so
> 
> 
> -----Original Message-----
> From: Tobias Larsson [mailto:tobias at kdab.net] 
> Sent: 30 April 2007 20:51
> To: Neil Paisnel
> Subject: Re: [KPhotoAlbum] KPA across network
> 
> Try to mount only the actual share, such as
> sudo mount -t smbfs //su/My\ Documents /home/Photos
> 
> Regards,
> Tobias
> 
> On Monday 30 April 2007 21.01.14 you wrote:
> > I asked a day or so back about KPA being used across a network, to where
> my
> > photos are stored on a networked Win XP machine.
> > I can see, and read/write to the folder from the kubuntu machine in
samba
> > shares.
> > I believe it was Tuomas who said that I first need to create a local
> > folder, and then mount the samba shares to that folder.
> > I tried as suggested, plus a host of other ways, but end up with the
error
> > as below.
> > Can anyone tell me where I may be going wrong.
> >
> > neil at Feisty:~$ sudo mkdir /home/Photos
> > Password:
> > neil at Feisty:~$ sudo mount -t smbfs //su/My\ Documents/My\ Pictures
> > /home/Photos
> >
> > mount: wrong fs type, bad option, bad superblock on //su/My Documents/My
> > Pictures,
> > missing codepage or other error
> > In some cases useful info is found in syslog - try
> > dmesg | tail  or so
> > neil at Feisty:~$
> >
> >
> > And here is the syslog entry
> >
> > Apr 29 20:59:01 Feisty kernel: [ 2741.864829] smb_fill_super: missing
data
> > argument.
> >
> >
> >
> >
> >
> > _______________________________________________
> > KPhotoAlbum mailing list
> > KPhotoAlbum at kdab.net
> > http://mail.kdab.net/mailman/listinfo/kphotoalbum
> 
> 
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at kdab.net
> http://mail.kdab.net/mailman/listinfo/kphotoalbum
> 




More information about the KPhotoAlbum mailing list