[KPhotoAlbum] KPA crashing on "wrong" export directory

Martin Jost lists at majo.name
Fri Jul 13 09:07:21 CEST 2007


Hello,

I just experienced my first complete crash of KPA.
I used "Plugins/Batch plugins/Resize Images"
As output path, I gave a path *not* under the KPA-root-directory for the
photos. KPA started converting the image and then (probably when it
tried to write the result out to disc), the attached error message came up.

(Sorry for the mixture of German and English; I tried to switch locales
using
godot:> export KDE_LANG="C.utf8"
godot:> export LANG="C.utf8"
godot:> kphotoalbum
What is the "right way" to do this ?)

Clicking "Cancel" (Abbrechen) and then "close" on the Batch resize
Window leads back to the main window of KPA. But unfortunately here no
photo was selected any more. (Which at first, when I tried to start the
Batch process again, lead me to the impression that now the menu entries
there, aren't working any more. Maybe the "Batch" plugins should be
grayed, as long as no picture is selected - maybe this is still more
confusing ;-(

Clicking "Continue" ("Fortsetzen") is even worse. KPA crashes with the
stack trace listed below.
On the bright side, KPA came up at next start, asking if a newer backup
copy of index.xml should be used. But nevertheless I see a risk of
loosing work here.

Martin

Stack trace of the crash:


Überprüfung der Systemkonfiguration beim Start deaktiviert.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1232332080 (LWP 12839)]
[New Thread -1256707184 (LWP 12843)]
[KCrash handler]
#9  0x080ef9cd in QMap<QString, Set<QString> >::clear ()
#10 0x080ee5d3 in Plugins::ImageInfo::clearAttributes ()
#11 0xb7f4572e in KIPI::ImageInfoShared::cloneData ()
   from /opt/kde3/lib/libkipi.so.0
#12 0x080ee09c in Plugins::ImageInfo::cloneData ()
#13 0xb7f3b19c in KIPI::ImageInfo::cloneData () from
/opt/kde3/lib/libkipi.so.0
#14 0xb52db3dc in
KIPIBatchProcessImagesPlugin::BatchProcessImagesDialog::slotProcessDone
() from /opt/kde3/lib/kde3/kipiplugin_batchprocessimages.so
#15 0xb52de7dd in
KIPIBatchProcessImagesPlugin::BatchProcessImagesDialog::qt_invoke ()
from /opt/kde3/lib/kde3/kipiplugin_batchprocessimages.so
#16 0xb52ca6d6 in
KIPIBatchProcessImagesPlugin::ResizeImagesDialog::qt_invoke
    () from /opt/kde3/lib/kde3/kipiplugin_batchprocessimages.so
#17 0xb702e3cd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb764944e in KProcess::processExited () from
/opt/kde3/lib/libkdecore.so.4
#19 0xb764960f in KProcess::processHasExited ()
   from /opt/kde3/lib/libkdecore.so.4
#20 0xb764319f in KProcessController::slotDoHousekeeping ()
   from /opt/kde3/lib/libkdecore.so.4
#21 0xb76432b2 in KProcessController::qt_invoke ()
   from /opt/kde3/lib/libkdecore.so.4
#22 0xb702e3cd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb702ef12 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb7368f80 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb704c5f0 in QSocketNotifier::event () from
/usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb6fcf647 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6fd04f9 in QApplication::notify () from
/usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb77191f2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#29 0xb6fc3e01 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb6f7eb04 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb6fe60e0 in QEventLoop::enterLoop () from
/usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb6fe5f76 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6fcf00f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x0807bbf2 in main ()


-------------- next part --------------
A non-text attachment was scrubbed...
Name: errormsg.png
Type: image/png
Size: 21869 bytes
Desc: not available
Url : /mailman/pipermail/kphotoalbum/attachments/20070713/57d3bfb5/attachment-0001.png 


More information about the KPhotoAlbum mailing list