[KPhotoAlbum] Current SVN broken?

Lars Clausen lars at raeder.dk
Sun Jan 28 10:38:42 CET 2007


I'm starting work on a plugin, but for that I need (I think) a working
KPA source, and the current build seems to be broken.  I did update,
autoreconf (should I have left that out?), ./configure and make, and
this is what I got:  

if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++
-DHAVE_CONFIG_H -I. -I. -I../.. -I../../kst/src/libkst
-I/usr/include/kde -I/usr/share/qt3/include -I.  -I./..
-DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall
-W -Wpointer-arith -O2 -Wformat-security -Wmissing-format-attribute
-Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common
-DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT
-DQT_NO_TRANSLATION -DQT_CLEAN_NAMESPACE -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION
-DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT
-DQT_NO_TRANSLATION -MT SurveyCount.lo -MD -MP -MF
".deps/SurveyCount.Tpo" -c -o SurveyCount.lo SurveyCount.cpp; \
        then mv -f ".deps/SurveyCount.Tpo" ".deps/SurveyCount.Plo"; else
rm -f ".deps/SurveyCount.Tpo"; exit 1; fi
/usr/include/exiv2/exif.hpp: In member function 'virtual const
Exiv2::Value& Exiv2::Exifdatum::value() const':
/usr/include/exiv2/exif.hpp:287: error: exception handling disabled, use
-fexceptions to enable
make[1]: *** [SurveyCount.lo] Error 1
make[1]: Leaving directory
`/usr/local/src/KPhotoAlbum-src/kphotoalbum/Survey'

I have compiled on this platform before.  My exiv2 version is 0.7-9.1
(Ubuntu).  Any suggestions?

-Lars




More information about the KPhotoAlbum mailing list