[KPhotoAlbum] compile error with kphotoalbum 3.1 - need some help...

Reimar Imhof Reimar.Imhof at netcologne.de
Mon Dec 10 22:35:17 CET 2007


Hi Jan,

here is the actual situation:
This error occurs only when I try to compile kphotoalbum within rpmbuild.
When I try to compile outside rpmbuild (just do an configure, make) it's 
compiling fine.
Now I've added an extra
export CXXFLAGS=' -ljpeg'
in die spec-file just before the configure-call.
That's an workaround for the compile error.
But I don't try to understand it, since configure set that flag by itself.
kphotoalbum seems to work ok, so I'm happy.
By the way: suse still provides kphotoalbum 3.0 on there 
kde-backport-repository. Strange...

Cheers
Reimar



Am Freitag, 30. November 2007 20:15 schrieb Jan Kundrát:
> Reimar Imhof wrote:
> > Hallo,
> >
> > I get an compile error with kphotoalbum 3.1.
> > I'm running openSuse 10.2.
> > I've tried the original (openSuse 10.2-) gcc (4.1.2 prerelease) and a gcc
> > version 4.2.
> > I get the same error.
> > Then I tried to compile the rc2. I still get the same error.
> > I'm able to compile kphotoalbum 3.0/3.0.2.
> >
> > The jpeg library and it's headers are installed (libjpeg/libjpeg-devel,
> > version 6.2.0-37)
>
> Hi Reimar, I wasn't able to reproduce your problem on Gentoo (gcc3) and
> Fedora 6 . Make sure you have installed this library into correct path.
> You might also try to ask maintainers of that package in your distribution.
>
> Cheers,
> -jkt
> _______________________________________________
> KPhotoAlbum mailing list
> KPhotoAlbum at kdab.net
> http://mail.kdab.net/mailman/listinfo/kphotoalbum


More information about the KPhotoAlbum mailing list