[KPhotoAlbum] Grid View: extra line on bottom ?

Jesper K. Pedersen blackie at blackie.dk
Mon Apr 30 07:07:52 CEST 2007


I'm afraid I dont remember details. I do rember that I had lots of problems 
getting things right when only a few thumbnails was shown. And again I dont 
know if that is relevant at all.

Feel free to fix.

On Sunday 29 April 2007 16:21, Henner Zeller wrote:
| Hi,
| In the process to 'get into' the code, I am right now looking into
| adding an option to the thumbnail view settings to choose the
| background color (I liked the black background for thumbnails in
| previous versions of kpa).
|
| Anyway...
|
| While reading the code (ThumbnailView/ThunmbnailWidget.cpp), I found in
| paintCellBackground() around line 423 the following code:
|         [...]
|         p->setPen( palette().active().light() );
|         p->drawLine( rect.left(), rect.bottom() -2, rect.right(),
| rect.bottom()-2 );
|         [...]
| .. basically adding another line at the bottom of the grid.
|
| I wonder why this is ? It makes the view more ugly because horizontal
| and vertical have different thickness and color. So I am inclined
| towards removing it (which indeed looks much nicer, especially with
| black background), but since this looks deliberate .. anyone knows why
| this is there in the first place ?
| Maybe a reason that is gone ? The svn-logentry of this change 497856
| (by Jesper)
| "use color themes in the thumbnail viewer"
| doesn't really help.
|
| thanks,
|   -henner

-- 
Having trouble finding a given image in your collection containing
thousands of images?

http://www.kphotoalbum.org might be the answer.


More information about the KPhotoAlbum mailing list