[KPhotoAlbum] kpaxml2mysql.py fails on my DB

Tuomas Suutari thsuut at utu.fi
Wed Apr 25 11:34:23 CEST 2007


On Wednesday 25 April 2007 03:57, Shawn Willden wrote:
> On Tuesday 24 April 2007 04:01:32 pm Shawn Willden wrote:
> > Time to fire up the debugger...
>
> Actually, no debugger needed once I looked hard at the conversion
> output.  I had 12 images (out of 12,412) that had invalid Token
> attribute values.  They all had the same strange value, too,
> Tokens="7536748".

Invalid values in the XML db should, of course, be handled some way.
In my TODO.



> Once I removed those, the conversion succeeded.  Anomalies I noted
> were:
>
> 1.  In the SQL DB I have two "People" categories, one that seems
> right and the other with no tags in it.
> 2.  Similarly, I have two "Places" categories.

This is because KPA's standard category names were changed after the SQL 
DB code was done. Also in my TODO.


> 3.  There are only 12,400 images, rather than 12,412,

This is probably because of those 12 images having invalid Tokens data. 
Could you check out if those have entrys somewhere in the SQL db?
SELECT * FROM media WHERE filename IN 
('yourfilename1.jpg', 'yourfilename2.jpg');


> Startup time is much faster, as I'd expect, and most other operations
> I tried seem noticeably faster as well.  Very nice.

Cool, that's nice to hear. :)


> Anything in particular you'd like me to try?

You could try those search querys for the quick search (from the mysql 
command line tool).

Query line can be found from my post here:
http://mail.kdab.net/mailman/pipermail/kphotoalbum/2007-April/002929.html

Maybe I'll bug you to test something else later when the backend code 
has some process again. ;-)

Thanks!

-- 
Tuomas Suutari | +358 50 3806983 | thsuut at utu.fi


More information about the KPhotoAlbum mailing list