[KPhotoAlbum] images size view fails: -1x-1 (0.0MP)

Shawn Willden shawn-kimdaba at willden.org
Mon Apr 16 06:30:31 CEST 2007


On Thursday 12 April 2007 08:49, Henner Zeller wrote:
> This has been addressed by one of my patches I did in late November
> ( http://vicdor.org/kpatches/ , infobox-after-image-load)
>
> I think it never got integrated because an early version of the patch
> had some problem, but I don't remember 

I downloaded your patch to look into it (and perhaps bring it back up for 
inclusion), and found that it does have a problem.  It doesn't work if you 
select multiple images and try to view them.  Specifically, it causes an 
unpleasant flickering as the info box is redrawn repeatedly on the first 
image being viewed (one redraw per selected image, I expect), and it also 
doesn't show resolutions on any image but the first.

I'll try to take a look at it if I get some time later in the week, because I 
think the basic idea makes a lot of sense, and because the -1x-1 is going to 
annoy users and prompt questions.  However, it might be quicker if you looked 
into it, since you have already made the effort to understand how that code 
works.

> (to be honest, I was a bit 
> disappointed that the development was a bit slow in November so I
> abandoned contributing .. this might change now as more people with
> more time are working on the core now).

We hope you'll reconsider contributing!

> Anyway, the other patches might be worth looking at as well, dunno
> which of them have
> been integrated.

I'm planning on taking a look at the others as well,

	Shawn.


More information about the KPhotoAlbum mailing list