[KPhotoAlbum] Little patch and some ideas I like to implement

Jesper K. Pedersen blackie at blackie.dk
Sun Nov 19 12:46:39 CET 2006


On Sunday 19 November 2006 12:00, Henner Zeller wrote:
| Hi,
|
| On 11/19/06, Jesper K. Pedersen <blackie at blackie.dk> wrote:
| > Right, with the current video support in KDE I dont have a way to ask for
| > the size of the videos. I'll make sure size is never shown.
|
| Well, the size of videos often is known, so in that case we _do_ want
| to show the size.
The problem is that the KDE framework I use for extrcting thumbnails do NOT 
tell me the size of the video.
|
| > | For me, it always displays 256x192 either for my 640x480 videos (my
| > | new cam) or my 320x200 (old cam), and sometimes -1x-1, and always
| > | "0.0MP" in the parenthesis.
|
| .. however, the 'Megapixels' are not very worth displaying for 320x200
| pixels. And for the unknown  -1x-1 sizes, the image size shouldn't be
| displayed at all.
|
| How about the following patch: image size is not displayed, if the
| size is unknown (however, still for videos, that actually have a
| size). Megapixels are only shown if the value is more than 0.1 (the
| display resolution).
|
| cheers,
|   -henner
That is all fine, but it all really boils down to the fact that I do not know 
the size at all for videos. Thus I'll keep the code as is.

-- 
Having trouble finding a given image in your collection containing
thousands of images?

http://www.kphotoalbum.org might be the answer.


More information about the KPhotoAlbum mailing list