[KPhotoAlbum] splashscreen

Christoph Moseler forums at moseler.net
Sat Nov 11 19:00:17 CET 2006


By solving one problem we made the next one, I think. The mainwindow 
doesn't get resized to the saved dimensions after starting kpa. If I 
remove qApp->processEvents(); restoring of the mainwindow's size is 
working fine, but the splash is not shown before loading the mainwindow. Hm.

config->readRectEntry( windowTypeToString( win ), &rect ); in
Settings::SettingsData::windowGeometry is returning nonsens 
(uninitialized random values) for x,y, height and width, if the 
outstanding events are processed, and the correct values, if the events 
are suppressed at this time (by removing  qApp->processEvents() ).

Because the default for the initial windowsize is 800x600, kpa is always 
shown in a very small window on my 1280x1024-screen :-(

I couldn't figure out, why that happens.

Christoph

Jesper K. Pedersen wrote:
> Actually I was wondering myself just an hour ago ;-)
> Thanks.
> 
> Jesper.
> 
> On Sunday 29 October 2006 22:56, Christoph Moseler wrote:
> | Hi Jesper,
> |
> | the splashscreen is not shown during the "Loading Database" phase.
> |
> | fix:
> |
> | bool MainWindow::Window::load()
> | [...]
> | -    if ( Settings::SettingsData::instance()->showSplashScreen() )
> | +    if ( Settings::SettingsData::instance()->showSplashScreen() ) {
> |          SplashScreen::instance()->show();
> | +        qApp->processEvents();
> | +    }
> |
> | Sorry for being a perfectionist ;-)
> |
> | Christoph
> | _______________________________________________
> | KPhotoAlbum mailing list
> | KPhotoAlbum-xItUb1CHQy4 at public.gmane.org
> | http://mail.kdab.net/mailman/listinfo/kphotoalbum
> 



More information about the KPhotoAlbum mailing list