[KPhotoAlbum] Something's broken in display of raw images

Robert L Krawitz rlk at alum.mit.edu
Fri Jun 2 03:37:45 CEST 2006


   From: "Jesper K. Pedersen" <blackie at blackie.dk>
   Date: Fri, 2 Jun 2006 03:17:42 +0200

   Tuomas (our Soc'er :-) already resolved this on trunk, so please go
   ahead and SVN up.

Thanks.

   On Thursday 01 June 2006 18:09, Robert L Krawitz wrote:
   |    From: "Jesper K. Pedersen" <blackie at blackie.dk>
   |    Date: Thu, 1 Jun 2006 15:16:09 +0200
   |
   |    I moved the thumbnail loader into a directory/namespace on its own,
   |    and might have broken this accidently.
   |
   |    I'll check up on it this weekend. Thanks for notifying.
   |
   | That's indeed what happened, as I described in my followup email.  The
   | problem is that these subdirectories are built as static archives, and
   | ld only pulls in the pieces required for linking.  Since nothing
   | directly references the RAWImageDecoder, it doesn't get linked in at
   | the final link step.  The only sign of a problem is that the
   | functionality isn't available at runtime.
   |
   | (BTW, you might want to make it more clear if ImageLoader attempts to
   | load a file and fails.  Right now the only thing is that a blank
   | screen gets popped up and stays "busy".  You can quit out of it with
   | <escape>, but the cursor stays busy.  This might be the cause of some
   | of the other busy cursor bugs -- if you quit out of loading an image
   | before the load completes, the cursor stays busy.)
   |
   | My general concern is that there might be other subclasses elsewhere
   | that don't show up cleanly.
   |
   |    On Thursday 01 June 2006 04:48, Robert L Krawitz wrote:
   |    |    Date: Wed, 31 May 2006 22:05:02 -0400
   |    |    From: Robert L Krawitz <rlk at alum.mit.edu>
   |    |
   |    |    Some time between roughly 05/21 and 05/27, display of RAW images
   |    | (at least .crw files from the Digital Rebel) broke.  What happens now,
   |    | at least on my system, is that when I double click on a raw image it
   |    | never displays; I just get a busy cursor.  I'll try to narrow down
   |    | exactly when it broke.
   |    |
   |    | Whatever broke was between revision 545606 and 545635.

   -- 
   Jesper K. Pedersen          |  Klarälvdalens Datakonsult
   Senior Software Engineer    |  www.klaralvdalens-datakonsult.se
   Prinsensgade 4a st.         |
   9800 Hjørring               |  Platform-independent
   Denmark                     |  software solutions

   _______________________________________________
   KPhotoAlbum mailing list
   KPhotoAlbum at kdab.net
   http://mail.kdab.net/mailman/listinfo/kphotoalbum





More information about the KPhotoAlbum mailing list