[KimDaBa] Load image progress bar doesn't appear right away

Jesper K. Pedersen blackie at kde.org
Sun Nov 7 17:32:50 CET 2004


On Wednesday 03 November 2004 05:28, Robert L Krawitz wrote:
|    From: "Jesper K. Pedersen" <blackie at blackie.dk>
|    Date: Wed, 3 Nov 2004 13:10:32 +0100
|    Cc: kimdaba at klaralvdalens-datakonsult.se
|
|    On Wednesday 03 November 2004 13:15, Robert L Krawitz wrote:
|    |    From: "Jesper K. Pedersen" <blackie at kde.org>
|    |    Date: Wed, 3 Nov 2004 08:39:17 +0100
|    |
|    |    On Wednesday 03 November 2004 03:53, Robert L Krawitz wrote:
|    |    | The load new images progress bar doesn't appear right away when
|    |    | starting up KimDaBa.  It appears that it's updated only every 10
|    |    | images or so, but it isn't displayed the first time.  This is
|    |    | very noticeable when I've created a bunch of 120 MB scans and am
|    |    | loading them for the first time.
|    |
|    |    Thats a feature of the scrollbar dialog. Namely not to show up
|    | before it is certain that the whole progress will take at least 4
|    | seconds.
|    |
|    | The problem is that it sometimes takes a minute to appear (if the
|    | images are very large).  It looks like it's only checking every
|    | 10 images or so?
|
|    I guess you are right that it only updates every 10 image. What
|    size of images do you have, that takes kimdaba more than a minute
|    to just run md5 sums of 10 images?
|
| 120 MB (4000 DPI scans of 35 mm film at 16 bit image depth).  If I
| were using medium format, it could easily be 300 MB.
|
| It actually takes about 3 seconds per image, so maybe the 1 minute was
| a little high of an estimate, but that's a long time for no response.
OK I've changed the code to update the scrollbar for each and every image, 
thanks for reporting.

Cheers
Jesper.
-- 
Having trouble finding a given image in your collection containing
thousands of images?

http://ktown.kde.org/kimdaba might be the answer.



More information about the KimDaBa mailing list