[KimDaBa] Lastest CVS: Kimdaba viewer only shows a black image

Rafael Beccar rafabeccar at speedy.com.ar
Mon Aug 23 14:15:02 CEST 2004


El Lun 23 Ago 2004 04:25, Jesper K. Pedersen escribió:
>On Wednesday 18 August 2004 18:50, Rafael Beccar wrote:
>| Hi,
>|
>| 	Yesterday I compiled Kimdaba from CVS and I noticed that although all the
>| thumbnails were generated, I couldn't see my pictures in Kimdaba viewer
>| because it only shows a black image. However, I can perfectly see the
>| image if I invoke an external viewer from Kimdaba.
>
>Strange, I dont see this. Is this both if you select one image, and a sey og
>images?

I noticed that it doesn't happen always (but it happen with all the images).
The problem only depends on the size of the viewer. So, I made this test
(with resolution 800x600):

Viewer size -> I get

- full screen -> black image
- 100x100 -> black image
- 150x150 -> picture
- 250x250 -> picture
- 200x200 -> picture
- 300x300 -> picture
- 320x240 ->picture
- 400x400 -> picture
- 500x500 -> picture
- 640x480 -> picture
- 600x600 -> black image
- 800x600 -> black image

Additionaly, I run kimdaba from command line and set the viewer to 800x600.
Then, I made double clic on a picture and  got a black image. When I tried to
zoom in on the image Kimdaba crash and I got the following on the console:

QPainter::begin: Cannot paint null pixmap
QPainter::setWorldMatrix: Will be reset by begin()
QPainter::setWorldXForm: Will be reset by begin()
QPainter::setWorldMatrix: Will be reset by begin()
QPainter::setWorldXForm: Will be reset by begin()
QPainter::setPen: Will be reset by begin()
KCrash: Application 'kimdaba' crashing...

Hope that helps

>Does anyone else have this problem?
>
>| 	A few days ago I made a full reinstallation of my system. So, I might be
>| missing some library. But I was allowed to compile successfully, though.
>
>I can't believe that should be the case.
>
>Cheers
>Jesper



More information about the KimDaBa mailing list